Announcement

Collapse
No announcement yet.

Phone to Expansion Hub disconnectivity

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phone to Expansion Hub disconnectivity

    We are using brand new (2019) REV Robotics Expansion Hubs with Moto E4 phones. We are struggling to get from a blue light to a green light on the expansion hub. Recently we had a system that worked without fail for 2 months, only to fail when we innocently decided to install a new Rev Robotics USB cable retention and mount. We were finally successful in connecting and getting the green light when we ditched the new, supposedly secure USB cable, with the old one.

    Finally, here's my question: We know that the Expansion Hub/USB micro - USB mini cable/phone triad is the ridiculously weak link in the whole system. We've done our best to install new cables and secure them. We're still struggling with unrepeatable results and random events. 1)Can someone suggest a DIY method for testing USB micro to USB mini cables, so we can eliminate that possibility? 2) The USB micro jack on the phone is getting so much abuse: is there a way to test that for problems?

    Thanks. Trying to keep the faith.

  • #2
    mudslinger
    A few things to consider:

    1. Did you have a chance to review the steps in the Online Tutorial that show how to connect and configure a phone to an Expansion Hub? In particular, you want to make sure the Expansion Hub hardware is by default associated with the FTC Robot Controller app:

    ConfiguringHardwareStep5.jpg

    2. There's an easy way to test your cables and your phone setup. First, make sure your Robot Controller (RC) phone is not physically connected to the Expansion Hub. Keep the two disconnected to start. Then power on the Expansion Hub with the main robot battery (while keeping it still disconnected from the RC phone). Then power on your RC phone and unlock the screen, but do not launch any apps on the RC phone. Then connect the RC phone to the USB Micro adapter cable. If everything is configured properly, and if the cable and USB connection is good, the RC phone should detect the Expansion Hub automatically, and the RC phone should launch the FTC RC app automatically. If it does not, then there could be something wrong with the connection or the phone's configuration.

    3. REV sells a USB retention kit that helps address this issue.

    I hope this info helps. Please let the board know if you have additional questions/issues. Also, if you do continue to have issues with connectivity, be sure to check out the FTC Wiring Guide, which has a lot of tips on how to wire and config your robot for optimal reliability.

    Tom

    Comment


    • #3
      Tom, thanks for your thoughtful reply. We have been diligently following all three steps you outlined. We had a functioning system until we installed the REV USB retention kit, which is when the connectivity conundrum started. We tried over 5 different cables ordered from various vendors until we finally found our original cable and were re-connected. When we test different cables using the method you outline in #2 we don't get consistent results. There seems to be some other variable in the system we're missing.

      Comment

      Working...
      X