Announcement

Collapse
No announcement yet.

Moto 5G crash

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moto 5G crash

    HELP! We have a competition in 2 days and our moto5g shutdown yesterday as if it were a dead battery. We plugged it in and left but this morning it won't come on. Black screen, no lights or indicators even when plugged in. I have tried the volumn/power restart, both up and down and it doesn't work.

    Ideas to try to get this phone working?

    quick ways to find and purchaase a new one?

    We have ZTE's as backups but Tensor flow documentation says it won't run on the ZTE. Could we use our one moto5g as the robot controller and a ZTE as the driver station? Is that legal and would it work?

    Any help would be greatly appreciated!

  • #2
    Originally posted by tcthomps1 View Post
    ... Could we use our one moto5g as the robot controller and a ZTE as the driver station? Is that legal and would it work?
    Absolutely... A lot of teams use the ZTE phone for the Driver Station and a non-ZTE phone for the Robot Controller.

    Comment


    • #3
      Originally posted by tcthomps1 View Post
      HELP! We have a competition in 2 days and our moto5g shutdown yesterday as if it were a dead battery ... quick ways to find and purchaase a new one?
      Also, reach out to the event director/coordinator. They may be able to loan you one of their spares, or help you find a team that will loan you a spare.

      Comment


      • #4
        We work on our robot in science classrooms where every outlet has a ground fault. We thought a phone was charging a while back and it wasn't, due to the ground fault being off. If your battery died and the outlet was dead, it could possibly be the same issue.

        Comment


        • #5

          Comment


          • #6
            Thanks for the responses. So I have what was the driver station moto 5g (with DS app removed ) reloaded as the robot control phone with the app modes uploaded from back ups to it. I have an old ZTE set up as the new driver station. The phones say they are conected , the DS has the right network listed says robot is stopped just like they are supposed to but when I try to run an op mode the DS acts like its running (timer ticking for autonomous) but the robot does nothing. THen it crashes when the op mode stops or is stopped. Any ideas? all the programs were working before.

            Comment


            • #7
              I would suggest posting the logs from the robot controller phone about the crashing.

              Additionally, if your phones are truly charged (try plugging in a known good charger with a device that notifies you about the charging state), you can typically hold the power button on a phone for a really long time to trigger a hard reset.

              Comment


              • #8

                Comment


                • #9
                  We tested the charger(s) with other phones and they are working...

                  We have tried the hard restarts repeatedly...

                  When it crashes (the program not the whole phone) It gives a message about Driver Control op mode stuck in stop mode or something similar, It goes away and then restarts the robot. When i choose and ititialize an opmode on the DS it displays it on the RC (So I know they are communicating?) but then when I hit start, it never acts like it is starting (The Tensor flow routine was the first evidence that that program was working yesterday because we have it set to be able to monitor on screen, today it never comes on screen. )

                  Comment


                  • #10
                    New developement... I created an opmode from a sample on the Tensor flow technology on the phones set up currently. It works! But the rest still just sit there? No errors until I hit stop . THen the robot has to restart. If the timer runs out on its own, no problem (other than it still does nothing.)

                    The tensor sample works and the phone monitor kicks in with telemetry working to the ZTE. Yet the op mode I have that we were already using which starts with that same tensor flow code as the first thing that happens doesnt ever turn on the phone camera. I am baffled!

                    Comment


                    • #11
                      OK, if your program gives that error when you hit stop, and then does a restart, it means that you have a loop (or while) in your program that is not exiting properly when the DS tells the opmode to stop. This is a very common, (and easily corrected) problem.

                      Check ALL your while loops. You should always have a opModeIsActive() check as part of the loop condition (Use the AND && logic). The most common place is where you are waiting for some move, or action to complete, or for a timeout.

                      eg:

                      Code:
                        
                      while (opModeIsActive() && (navTime.time() < wristTimeout)) {
                              runPIDs(true);
                      }

                      Comment


                      • #12
                        Further reading your issue..... I suspect you have a while loop that never terminates. that's why your robot just sits there.... it's stuck in a while loop.
                        Look at your while loops very closely.... or post your code in a code block here.

                        Comment


                        • #13
                          I am checking but I really don't think this is the issue. THe programs were all working before the first phone bricked and now NONE of them are working and all giving the same error.

                          Comment

                          Working...
                          X