No announcement yet.

Problem Connecting 2nd Rev Extension

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem Connecting 2nd Rev Extension

    We are trying to add a 2nd Rev Extension Hub and having problems. I watched video and read the Rev guide. I individually adjusted the id/address for both units. I assigned the main unit (connected via USB to phone) as 2 and the add on unit as 3. I wired the power from the first to 2nd unit and added the 3 pin JST connector to the RS485 port on both units.
    When I go into configure robot and edit a config or try to add a new one, I do not see the 2nd expansion hub under the portal of the 1st - it is always just the main hub listed.
    I have tried multiple app closes and power cycles (phone and Revs) to no avail. Any help would be greatly appreciated, as we have a qualifier tomorrow.

  • #2
    Did you scan the bus with BOTH hubs connected and powered up (flashing blue)?

    note: Once you scan the bus with only one hub attached, it will not automatically add a second hub.

    If you did try scanning both, did you see any change in the LED activity on either/both hubs.


    • #3
      I was under the impression that a scan occurred when you create a new config. Even so, I created new config and selected scan and same results - only the 1st hub shows under the portal. I've tried two phones, two different 2nd hubs, many, many cycles, etc. No glory.
      I am using the black, blue, and white cable that came with the Rev unit. Is this the correct cable? I am plugging in to the RS485 on both hubs - and I've tried both ports.
      I will have a different cable tonight - will try that.
      Any other tips?


      • #4
        BTW, the first hub flashes blue when there is no config set and there is 12V power and phone connected. The 2nd hub is solid blue.


        • #5
          Problem solved - it was a bad 3 pin JST wire in the pack from Rev. 2.5 hours that I will never get back. Philbot - Thanks for the suggestions.