No announcement yet.

Moto G gen2 phones unable to do jack!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Moto G gen2 phones unable to do jack!

    Rookie Coach, trying to get the Moto G gen2 phones to test motors. Making some headway in some ways with the configuration but the devices are still not communicating to each other. Please help. I'll buy you a pizza.

  • #2
    This won't help you, but hoping you can help me. We are connecting all the pieces and parts to the phones and discovered we need another Micro to USB OTG cable. The FTC official kit from Pitsco only sent us one. Am I missing something or doing something wrong? Please let me know if one is all we need and we've set it up wrong or if you did like I did and just picked another one up.


    • #3
      You should have a white mini-to-micro OTG cable, that is used on the robot to go from the robot controller phone to the power distribution module. Check all your white cables closely, you may have missed it. You should have a black micro-to-USB cable, and a USB hub that are used with the joysticks and the driver station phone. You should not need a second micro-to-USB OTG cable. If you are missing the white mini-to-micro OTG cable, you can use a micro-to-usb OTG cable and a usb-to-mini cable instead, but you'll need to get another micro-to-usb OTG as only one is included.


      • #4
        Coach C,
        I've had similar problems with Moto G 3's. I often seems to need to go into the Wifi --> Advanced --> Wifi Direct settings and mess around there. Disconnect and re-connect the Wifi direct connection there. and then go back into the FTC apps and connect the phones.

        Go into the Settings of the FTC apps in both phones and select Self Inspection, it may point out some issues.
        eg. you should set Airplane mode on, and then go and turn on wifi.
        Are your phones named properly? eg. 12345-RC and 12345-DS

        Follow the instructions in the FTC training manual about setting up and connecting phones if you haven't tried that already.

        I just realized you say 'devices' and not phones. So are your phones not talking? or can your robot controller not see your USB devices?
        A little more description and any actual error messages would help.