No announcement yet.

wifi direct connection issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • wifi direct connection issue

    We are having trouble connecting our ZTE phones. It worked last year, but since installing the new apps and SDK, the phones won't connect.

    With both Robot Controller and Driver Controller apps running, the driver phone requests connection with the robot phone. We accept on the robot phone. The driver phone then says Network: Connecting, but it never actually connects. It eventually resends the invitation to connect again.

    I've tried using the wifi direct connect in the settings(not running either ftc app) and I can't connect them either.

    Both phones have android 4.4.4 installed.
    Both phones have App version 2.2, library version 16.08.19, and wifi protocol v11
    Airplane mode is on (i've tried it with that off too). And neither phone is connected to a wifi network.

    Any suggestions?

  • #2
    Are you trying to connect the phones in an area that is saturated with WiFi signals or even WiFi blocking signals? We had a similar problem last year when our HS started setting up the WiFi network security for ISTEP testing. They specifically had WiFi canceling repeaters that blocked all WiFi signals that wasn't on their OK list in the area to prevent cheating and to allow better connectivity to their devices. We could only connect the WiFi direct when we walked 20 feet away outside the building. Once we paired them and everything was working correctly, we would go back in the building and as soon as we got in the doors they would loose connection to each other. This really put a damper on our ability to test our programs.

    If both apps are version 2.2 and the same libraries then that should not be the problem.

    Make the phone "Forget" the other previously connected WiFi connections? This helped us last year too. Completely reboot the phones may help (assuming you already did that though)

    Does the Self Inspect feature in the menu on the new apps have any red values? If there is then that could be a clue. WiFi connected should be a Green "No" value.

    Maybe even Phone battery level is too low could be an issue.


    • #3
      We made the mistake of trying to pair them under the wifi menu and that messed up the pairing in the ftc apps. We ended up unpairing in wifi settings, restarted both phones then only paired in the ftc apps. That seemed to work for us. There is a post on this forum that mentions this but I can't find it at the moment.


      • #4
        The Self Inspect shows all green values, including WiFi "No". There aren't any WiFi connections saved. I have tried restarting several times. I don't think our school is blocking anything, but I tried going outside just in case. Nothing worked.

        Our phones won't pair up in or out of the app. So I can't unpair them in the wifi direct menu. Each phone shows the other as being available, and they can send the invites, but they don't connect.


        • #5
          For further information, we are encountering the exact same problem, just as you described it.

          We are a rookie team, and have received our 2 Moto G3 phones from the Pitsco storefront. Following steps found in guides, we have downloaded the two apps (one on each phone), renamed the Wifi Direct to FTC naming conventions, and now try to pair them in the apps. We receive the invitation on the RC app, but the DS app just says "connecting..." and seems to hang there. Similarly, we tried to pair them directly in the Android settings (after reboots and other attempts) and we receive the same problem: an invitation sent and accepted, but no actual pairing.

          Other details I've noticed:
          The DS "Connect" option has a toggle for filtering the devices found. It only sees the RC when we turn off the filter (that may be by design?)

          Since we are using the Moto G3, we are on Android 6.x...I don't have the exact details for versions in front of me.
          We are in a high wifi traffic area, and I will try to move out of that area tomorrow and try again. No blocking of WiFi exists (as far as I know).
          Airplane mode is on and neither is connected to any other WiFi network.


          • #6
            You mention "we have downloaded the 2 apps". Your case may be different but for us the robot controller should not be downloaded from Google but should come from Android Studio.


            • #7
              Originally posted by timsteen View Post

              The DS "Connect" option has a toggle for filtering the devices found. It only sees the RC when we turn off the filter (that may be by design?)
              Actually, the filtering works exactly the opposite to what you have described...

              The device filtering is used to limit the number of devices being displayed.
              When filtering is ON, it should only show phones that have a "name" compatible with YOUR Driver Station name.
              When filtering is off, it shows all available devices.

              If your RC is not showing up with the filer ON, then you have naming issues.

              eg: Both the RC and DS names should start with the same team number.

              They should be of the form... 1234-DS and 1234-RC
              1234-A-RC and 1234-A-DS

              Perhaps you should try re-doing both names (making sure you don't include any weird characters (like spaces, returns etc))

              Note: You need to fully delete and "forget" any existing network/device names =in order for the configure/device option to show up.


              • #8
                Solved my problem.
                I brought the phones home and they now connect. So I'm guessing that there are just too many wifi signals available at my school and it was jamming the phones. Is that what the wifi changing app is for? Should I have tried using different channels that weren't so busy?


                • #9
                  Originally posted by Philbot View Post
                  Actually, the filtering works exactly the opposite to what you have described...
                  If your RC is not showing up with the filer ON, then you have naming issues.

                  They should be of the form... 1234-DS and 1234-RC
                  Update on troubleshooting we did on Saturday:

                  1. Yes, I did name the WiFi names slightly wrong. I used underscores instead of dashes in the name. Changing it to dashes allows the filter to work.

                  2. We took the 2 phones outside of the room we were working in. At first, we went outside...and they connected immediately. We wandered around our school, and the phones stayed connected in every area. Except for when we neared about 5 feet from the computer lab, where the FTC team meets and works. The phones disconnected (with the above description of "connecting..." but hanging) in the lab and adjacent Media Center. As soon as we leave this area, the phones connect again. We're looking into anything that might make this area different from the rest of the school.


                  • #10
                    We finally solved our problems with Moto G (2nd gen) connectivity. Our school runs a program called Air Marshall, which prevents local hotspots from being created, enhancing network connectivity. This prevented our phones from being able to communicate using Wifi Direct. One phone would receive the invitation, but the other phone would keep trying to connect. Once our IT administrator whitelisted our phones, everything started working. Thanks to those who suggested to bring the robot outside the school, because I probably wouldn't have solved the problem without it!