Announcement

Collapse
No announcement yet.

Phone and Expansion hub connection issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Phone and Expansion hub connection issues

    FTC guru's
    Coach Jeff of Team 12913 here, we're having an issue connecting the RC phone and the DC phone and hubs(2 REV hubs). At times the phones won't connect at other times it won't let us start the programs and sometimes an expansion hub is missing. It does it randomly and we will mess around with the config and connections and restarting the phones and apps. it will randomly start working and stop working. We have 4 AndyMark Neverest 40 motors 2 Tetrix motors 4 tetrix servos and one MR range sensor(I have checked wiring numerous time it is correct). We just recently updated to the app to version 3.6 and that is when our problems started. Here are answers to questions posted by Philbot to help explain our issue. We tried restarting phones and apps. Thank you in advance for any suggestions!

    1) What type of robot hardware are you using? REV Expansion Hub (2 hubs)

    2) What type of phone are you using? Motorola XT1609

    3) How did you transfer the FTC App to your Phone? Play Store download

    4) What is the version of the RC App? 3.6

    6) If you are having trouble configuring your robot, are you using the RC phone to do it? We have tried both
    If not (you are using the DS phone), you MUST have paired with the robot and be connected (Numbers showing in Ping Times)

    7) Is this a problem that has started since you made a change to the system? Yes, updated the phone apps. Also added MR range sensor and correctly wired.

    8) If you need help doing something new, have you checked the sample programs to see if there is already an example for you to emulate? Not applicable

    9) If you are having crashes or disconnects or anomalous behavior, be ready to provide a copy of you log file (found on phone) to help in debugging. We cannot find the log once downloaded, and haven't had one long enough to help probably.

  • #2
    The log files will either go where you put them, or into your standard browser download folder.
    Robot Controller log files are always long, so you should try to locate them. They are the best recourse for resolving problems.

    The fact that you have the MR Range sensors makes me ask if you have upgraded your Rev Expansion hub Firmware.

    You can tell this easily by answering this question:

    If you turn off the 12V, but leave the phone plugged in, what do the LEDs on the Expansion Hubs do?

    If they blink orange, then you have at least 1.7 so that shouldn't be an issue:
    If they are still green/blue then you need to upgrade from 1.6 to the latest 1.7.2.

    The old software is problematic for 2 reasons:
    1) MR Sensor issues can cause the hubs to get confused, and this may be triggering your problem,
    but more importantly,
    2) It's easy to forget that the when you turn off the robot, or the battery dies, the pone is having to keep everything powered.
    With two hubs, my experience is that this causes lots of communications issues, many of which continue after you turn the power back on.

    We always adopt this power on/off sequence.

    To turn on

    1) Ensure that the RC App is swiped off, and the phone is un-plugged..
    2) Turn on 12V,
    3) Plug in phone, observe that the app Auto Launches... If it does not then there is a cable problem between the phone and Hub.

    To Tun off

    1) Unplug or power down the phone
    2) Turn off the 12V

    Comment


    • #3
      Philby - thank you - will update the firmware and continue to troubleshoot at our next meeting and get back to you - thanks again

      Jeff

      Comment


      • #4
        Updated the firmware and followed Philbot's suggestions - it works - thank you very much!

        Comment


        • #5
          I made a new configuration file from scratch. Worked. That

          Comment


          • #6
            (got chopped off) also worked for daveshus and Tom on this forum.

            Comment

            Working...
            X