Announcement

Collapse
No announcement yet.

HELP --- Motor Power Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP --- Motor Power Issues

    All of our teams are having major issues with coding our non drive motors. We are using the same block code as last year which worked just fine but for some reason, this year, those same blocks don't work. Here is a pic of our blocks https://goo.gl/X0VhYa. We are using if statements to turn a spinner forward and backward. Are we doing something wrong in the code??

    Thanks

  • #2
    We always add Else statements to set them to 0. And make sure your phone "configuration" matches with all the naming conventions (lowercase vs. capitalized, etc). Those are basic troubleshooting tips that I can offer.

    Comment


    • #3
      Here's a copy of part of our team's code. You can see the Else statement in the TeleOp. We always use stops and pauses, the robot behaves better, especially in Autonomous.

      https://www.dropbox.com/s/0b8kvzlkk7...tout.docx?dl=0

      Comment


      • #4
        My son says set the "if, then, Spinner" from -1 to 1, and add a "set Spinner Direction to REVERSE" above that.

        He also says you need to add the "else" blocks by clicking that blue gear icon, drag the "else" out, make sure not "else if." Have that set Power to 0, do that to both spinner blocks.

        Comment


        • #5
          Originally posted by RoboticsFun View Post
          My son says set the "if, then, Spinner" from -1 to 1, and add a "set Spinner Direction to REVERSE" above that.

          He also says you need to add the "else" blocks by clicking that blue gear icon, drag the "else" out, make sure not "else if." Have that set Power to 0, do that to both spinner blocks.
          This here should help you most. I would add a note to really make your code strong, add a "Set right_drive Direction to 1 in the very beginning, under that first call block, otherwise, if you have autonomous programs, they can mess up your TeleOp. But if you don't have autonomous, you can get by without setting it.

          Comment


          • #6
            What specifically is going wrong?

            Comment

            Working...
            X