No announcement yet.

LogiticC310 Webcam Configuration

  • Filter
  • Time
  • Show
Clear All
new posts

  • LogiticC310 Webcam Configuration

    We purchased the recommended webcam, Logitech C310 and recommended powered USB hub. We have everything wired. We found where to put the the calibration file on our robot phone. However we have no idea where to get or create this file. We are using FTC blocks programming. If you have any suggestions or could share some insight it would be tremendously helpful. We would really like to get the camera mounted and start using it before our next competition. Thanks

  • #2
    This file may be what you're looking for.


    • #3
      Let me try again:


      • #4
        YES, thank you schaferbw!! We have a new problem. I'm sure it is a simple fix. I uploaded the file I believe correctly to our phone configuration. I opened the RAW file, Saved As (I believe an .xml file is correct), uploaded and it seemed to be successful. However I am still getting the error: Warning: Incorrect block plugged into the cameraName socket of the block labeled "call Vuforia.initialize". Expected CameraName." Do I somehow need to upload this file in to Blocks? Is that a thing?

        I uploaded a photo of our opMode and the Sample opMode and I have noticed that in the sample it appears that they are selecting a camera named WebCam1 in that block. There is a little drop down arrow. We do not have that option and that is the block that our Warning is coming from. Our example does say WebCam1 but I am unable to change the name or select a different name. Any ideas? I'm sure someone must have set this up at some point. THANKS



        • #5
          You need to add your camera to your config file. Plug it it into your powered hub, turn everything on, go to configuration on your RC phone and do a scan. The camera to should show up at the top level, next to the expansion hub portal. Give your camera a name and then save the config file. From your web browser go back to your list of op modes and reselect your webcam opmode. Your camera's name should now be available.


          • #6
            2 for 2!! Thank You so much!! Hopefully one last question. Webcam is up and works and seems to have a very narrow field of view. Any way to open that field of view or is that just what the settings need to be for that camera? Thanks


            • #7
              I haven't personally set up an external camera so I'm just guessing. Here's my guess: The xml files has calibration information for a bunch of cameras but they are preceeded by XML comment characters. If you haven't done so already, you need to take the comment characters out for your camera so that part of the file is actually used.