Announcement

Collapse
No announcement yet.

REV HEX Core motors library

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • REV HEX Core motors library

    Which one is the right library to make the REV HEX Core motors move using the controller? We thought it could be BasicPOVDrive, but no response from the RC's console is given, from neither the Y nor X axis of the controller's sticks. Do I have to change any of the variables, or we're simply using the wrong program? The name for components seem to match the ones set in the pin configuration.

  • #2
    All motors will work with the demo programs.

    Have you "Selected" the gamepad?. That is, designated the gamepad as driver A or Driver B.

    The examples all assume driver A, so make sure you hold the START button on the gamepad and click the A button.
    The left gamepad icon should light up at the top of the Driver Station.

    Check the Battery voltage display on the Driver Station.
    It should be green.
    If it's red and reading 6 volts, it means you don't have the 12V power turned on. The motors won't run without 12V

    If you've done all that, are you getting any error messages?

    Comment


    • #3
      Originally posted by Philbot View Post
      All motors will work with the demo programs.

      Have you "Selected" the gamepad?. That is, designated the gamepad as driver A or Driver B.

      The examples all assume driver A, so make sure you hold the START button on the gamepad and click the A button.
      The left gamepad icon should light up at the top of the Driver Station.

      Check the Battery voltage display on the Driver Station.
      It should be green.
      If it's red and reading 6 volts, it means you don't have the 12V power turned on. The motors won't run without 12V

      If you've done all that, are you getting any error messages?
      I was skipping the step to connect the controller by pressing START and A. I thought this wasn't needed because the controller was already working with a videogame. Other than that everything worked well and I didn't get any error message.
      Thank you!

      Comment

      Working...
      X