Announcement

Collapse
No announcement yet.

Problems with installation of project folder

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with installation of project folder

    I'm trying to install the android studio project folder, but it seems to me like something is wrong. I've checked multiple tutorials, and they only get three main folders when the installation of the project is done; FtcRobotController, TeamCode and Gradle scripts. But when I install the project folder (https://github.com/ftctechnh/ftc_app/releases, dowloaded the source code zip V4.3 and extracted it) I get way to many folders, and also som strange errors. What am I doing wrong?

    android1.JPG

    android2.JPG
    Attached Files

  • #2
    Click on the triangle to the left of the ftc_app folder to collapse the tree.

    Comment


    • #3
      I know I can click on the triangle to collapse the tree, but every tutorial I've seen doesn't have a this long "tree", they only have three folders in the tree. It seems to me like something is not right, but I don't know exactly what.

      Comment


      • #4
        OK, yeah your display is different than mine, but I can show the list you have by clicking the blue square.
        Does it work? Can you click on the green triangle compile, and download a working opmode?

        I don't know if you have somehow selected a different view option, or if something is wrong.


        Comment


        • #5
          That is what mine looked like before I had accepted the Android SDK licenses. Have you done that? Try to build and see if it builds or if the errors give you a clue.

          Comment


          • #6
            Yes I'm able to collapse the tree, but don't have acess to a robot at the moment so can't check if the compile and download works. I tried to build and got some errors. I installed some files and accepted the licenses. Then it built sucessfully, but it still looks strange. I don't know if I have accepted all of the Android SDK licenses, so where can I do/check that?

            Comment


            • #7
              If you are getting it to build, you have accepted all the SDK licenses. (You can check to see what SDKs you have under Tools/SDK manager). I might change from "Android" to "Project" and back and see if your tree collapses.

              --Alan

              Comment


              • #8
                Thanks, that fixed it. "Android" was the right choice

                Comment

                Working...
                X