Announcement

Collapse
No announcement yet.

[CANNOT RUN] Device supports, but APK only supports armeabi-v7a

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CANNOT RUN] Device supports, but APK only supports armeabi-v7a

    Happens when choosing a device at run. Device shows as "2c3197bd[null] (Device supports, but APK only supports armeabi-v7a)".
    Force clicking OK causes it to grey out and the message "Device supports, but APK only supports armeabi-v7a" to show up in red under "Create New Virtual Device".
    Screenshot from 2019-03-04 12-42-51.png

  • #2
    This happens if you're using wireless ADB and the computer disconnects from the RC's AP without you doing "adb disconnect 192.168.x.xort". The simplest way to fix it is to do kill the adb server and reboot the phone.

    Comment


    • #3
      That also happens if you haven't accepted the computer you are talking from as one that can work over USB Debug with the phone. (You'll get a dialog on the phone with the fingerprint of the computer)

      Comment


      • #4
        Originally posted by alan_16072 View Post
        That also happens if you haven't accepted the computer you are talking from as one that can work over USB Debug with the phone. (You'll get a dialog on the phone with the fingerprint of the computer)
        Apparently it had nothing to do with USB debugging nor ADB. I commented out all the lines in build.gradle that contained the armeabi-v7a (which appeared twice) and the device APK support error didn't show up anymore.

        Comment

        Working...
        X