Announcement

Collapse
No announcement yet.

Android Studio 3.3 just won't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Android Studio 3.3 just won't work

    Hello Everyone,

    Hopefully someone can shed some light on our problem. Our team is expanding and we needed a new computer. We currently have all Mac's and didn't have the money to get another laptop. So we ended up getting a window's machine. I have used Mac's since 1989 and never used a window's machine. I thought my problem was with that but our IT guy can't even get AS to run.

    We downloaded AS 3.3, unzipped the FTC app master, made sure we had Java installed. We just keep getting error after error. One of the problems is that we can't make Java files. We read all the posts about that and nothing. Then the gradle was not the right version, and several others. We have been able to load AS 3.2 on all our macs and have it fully functioning.

    What are the steps to get AS 3.3 to work with the FTC app master? We need some major help, it should be A LOT easier to get this up and running. Thanks for any help you are able to give!!

    Douglas J. Merritt
    Robotics Advisor
    Mountain Lakes HS
    #8816
    #10788


  • #2
    Perhaps someone has a link that my team could follow to some steps on how to install properly? Our IT department has downgraded AS to version 2.2 and now things are really messed up. Or can someone post that they have successfully used AS 3.3 on a windows machine? I just can't see how this should be this difficult.

    Comment


    • #3
      I just updated from 3.2.1 to 3.3 on my PC. I did not choose to update Gradle. It caused problems in earlier versions of the SDK (but I think has been fixed, just haven't tried yet.) It compiled SDK 4.3 and I ran NullOp on the phone. All of our opmodes are still in teamcode, so everything was compiled.
      Did you disable Instant Run?
      First time you run the SDK you'll have lots of errors about missing parts. Under the error it asks do you want to install it. Click on it and they install.

      Install guide
      Chapter 9 -
      https://www.firstinspires.org/sites/...o-tutorial.pdf

      Comment


      • #4
        #3805Mentor,

        Thanks for getting back to us. We have disabled Instant Run. Whenever we ran the SDK on the macs, Yes, we got several errors that we then clicked on and they installed and eventually everything compiled. However, on this new windows machine, that never happened. It just gave us errors like the Gradle needed updating. We will try again on Monday and see if not upgrading the Gradle will work. Thanks for your help!

        Comment


        • #5
          #3805Mentor,

          So I reinstalled AS 3.3 and got some of the same errors I did before. However, when it said to upgrade Gradle, I said NO. I did have to go under the file menu and sync project with Gadle Files and all is now working. Thanks for your help!!

          Comment

          Working...
          X