Announcement

Collapse
No announcement yet.

Warning Problem with Modern Robotics Sensors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Warning Problem with Modern Robotics Sensors

    Hi, we are having an issue with our robot where whenever we try to use Modern Robotics i2c sensors, we get an issue "Problem with r" (r is the name of our modern robotics range sensor) and "Problem with g" (g is the name of our gyro sensor. We have two Rev Expansion Hubs with 6 motors, 2 servos and a webcam. We had this issue earlier in the year but we somehow fixed it by putting one sensor in one expansion hub and putting another sensor on the second hub. However, today during our competition, it occurred and nothing we tried fixed the issue. We tried replacing the wires and Logitech converters and we even updated the firmware. However, the issue still persists. We even tried using a different range sensor. Any help would be greatly appreciated.

    Thanks!

  • #2
    I have several times had the auto complete change the name in the configuration file without my noticing it.
    Configured the right I2C port number?
    Selected Modern robotics for the type of sensor in the configuration file?
    Did anyone change the sensor from the default address? (use the Core Device Discovery software)
    Are you using the adaptor cable that swaps two wires?
    Have you double checked that the non polarized plugs are not reversed?

    I've discovered 2 jst cables and one level shifter were bad so far.

    Comment


    • #3
      Due to us having the same issue, we had gone through multiple connectors and Modern Robotics gyros.
      The solution we had done was switch out the connectors, as switching the gyro sensor had no affect compared to the connector.
      Hopefully this helps! From the programmer of 9362.

      Comment


      • #4
        Originally posted by lane14741 View Post
        Due to us having the same issue, we had gone through multiple connectors and Modern Robotics gyros.
        The solution we had done was switch out the connectors, as switching the gyro sensor had no affect compared to the connector.
        Hopefully this helps! From the programmer of 9362.
        Thank you both for your input. During the competition, I had only changed the Logitech converters for our motor encoders wires because we were having issues with our motor. I realized I never actually changed the converters for the sensors. It totally slipped my mind. I will try this in a next couple of days and hopefully its get fixed. Thank you again!

        Comment

        Working...
        X