Announcement

Collapse
No announcement yet.

Moto E4 direct wifi connection from PC disconnects when USB cable removed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Moto E4 direct wifi connection from PC disconnects when USB cable removed

    Our team has just switch from ZTE Speeds to Moto E4s. We can establish a direct wifi connection to the laptop in the normal way:
    • plug phone in with USB cable to laptop
    • connect to RC app on phone with laptop wifi
    • C:\windows\adb.exe tcpip 5555
    • c:\windows\adb.exe connect 192.168.49.1
    All looks good. When we hit play/build in android studio both the usb connection and the wifi connection to the phone show up in the dialog box. The phone stays connected via wifi as long as the USB cable is plugged in too. As soon as the USB cable is removed, the wifi connection to the phone is lost. I guess to be more specific, the wifi connection remains but the phone is no longer connected via ADB. USB debugging is enabled in developer options.

    This is the same process we use for the Speeds and it works.

    Any ideas are appreciated because loading and debugging without wifi connection to the phone is a major impediment to productivity.

  • #2
    after unplugging the USB cable, run again
    • c:\windows\adb.exe connect 192.168.49.1:5555
    this works for us.

    Comment


    • #3
      Thanks FTC12611. That did the trick. We added that command as an external tool command to make it easier to run.

      Comment

      Working...
      X