Announcement

Collapse
No announcement yet.

Op Mode Not Registering

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Op Mode Not Registering

    We just made a new Op Mode to test our new Prototype. We are using Android Studio. We hit the download button and plug in the phone but the Op Mode doesn't show up. We registered the Op Mode in FtcOpModeRegister, ConceptRegisterOpModes, and we put the following code into the actual OpMode to try to register it: @TeleOp(name = "TeleOp Coolness", group = "TeleOp"). We are using Motorola Moto G3 phones.

    Anything you know would be helpful,
    --Klamath Coyotes (10060)

  • #2
    Sounds like you are trying to follow the instructions in the Pushbot guide around page 71? If so, don't, those are not the right instructions for the current version of the FTC SDK. For the current version, your best bet is to copy one of the existing OpMode examples, then modify it/add your code. Starting with the template for the iterative opmode, you just comment out the @Disabled line and then add your code in the appropriate places elsewhere in the file.

    Code:
    @TeleOp(name="Template: Iterative OpMode", group="Iterative Opmode")  // @Autonomous(...) is the other common choice
    // @Disabled
    public class TemplateOpMode_Iterative extends OpMode
    {
    That's what the start of the template would look like, your class name will be different. When you use copy/paste in Android Studio for the sample class, you should get a dialog box that allows you to rename everything somewhat automatically.

    Put the FtcOpModeRegister file back the way you first found it.

    Comment


    • #3
      Thank you so much, this helped and we can now download opmodes onto the Motorola phones.
      --Klamath Coyotes (10060)

      Comment

      Working...
      X