Announcement

Collapse
No announcement yet.

Can't Initialize and Stock Andriod?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Initialize and Stock Andriod?

    Our team's practice today consisted of about 2 and a 1/2 hours of attempting to get our phones to function correctly. One of our coaches took the phones, both phones are Moto G Play, home to update Android over New Year's Eve/Day. She said it took 3 hours to go through 4 update batches. Today, when we started our robot, pushing the Initialize button on the driver station did nothing. Some things we concluded during that period:
    • This is not a version mismatch issue because both phones are running Android 7.1.1 and FTC Apps version 4.3, and we uninstalled and reinstalled both apps mid-practice with no difference
    • This is not a phone to phone communication issue because when attempting to initialize without the robot controller plugged into the REV hub everything worked as expected.
    • This is not a wiring issue because all cords were double checked, and the Mini-USB connecting the REV Hub to our robot controller, which had a slight slit, was replaced with no difference
    • This was not a power related issue as we tested with a freshly charged battery
    • This is not a code related issue as we tried to run a new, blank OP mode with no success (we use Blocks if that makes a difference)
    • We believe the robot controller was having trouble communicating with the REV Hub because in the Logs there were repetitive "LynxModule Unknown Command" and "LynxModule Retransmit Command" messages, and these only appeared when the robot was plugged into the REV Hub (I don't think that was the exact wording but I'm unable to check as I don't have the robot at my house)

    Towards the end of practice, we accidentally left the phones running while cleaning up something else. It took 45+ seconds, but we were able to make it past the initialization state. Since there was not much time left, we didn't have much time to investigate. We discovered the state on the Robot Controller changed to initializing around 15-20 seconds after pushing the button on the Driver Station. We were able to start our tank drive OP mode, but it would not respond to any of our input.

    Since the only possible source of change we knew of was the android updates installed, I offered to take the phones home and image them with stock Android. Before I did that though, I thought I'd explain our situation here to:
    1. See if anyone could offer any alternative fixes
    2. Check if using stock Android is legal for competitions.

    Any help is greatly appreciated!

  • #2
    Didn't work on Thursday, but works on Saturday. We did nothing in between the days. Super bizarre!

    Comment

    Working...
    X