Announcement

Collapse
No announcement yet.

Color Sensor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Color Sensor

    Hello!

    Our Team is having trouble getting data in Autonomous from our Modern Robotics Color Sensor. TeleOp works just fine, we can get data. In Autonomous, the telemetry doesn

  • #2
    If you use the same setup in both modes, you should get the same data.
    Are you using different opmode styles?

    Comment


    • #3
      Yes, we were using Iterative for TeleOp but were not using Linear for autonomous. Thank you so much for helping!

      Comment


      • #4
        Sorry, I meant to say we were using Linear OpMode for autonomous and Iterative for TeleOp. It is now Iterative for Autonomous and we are getting color sensor data.

        Comment


        • #5
          Sorry, I meant to say we were using Linear OpMode for autonomous and Iterative for TeleOp.

          Comment


          • #6
            If you started getting data by switching to iterative, I would suggest you look into if your first reading is not working properly. Iterative might be looping through and taking multiple readings and eventually getting something.

            Comment


            • #7
              May I ask what you are using the color sensor for? If using it for sampling for gold mineral location, I highly suggest you abandon this idea and go with the TensorFlow approach. We wasted countless hours trying to use the color sensors to no avail. You have to be too close to the mineral, it is too slow, and it is affected too much by lighting in the room. Our Tensorflow implementation is now 100% over 50 trials. Yes, there is work involved in getting Tensorflow to 100%, but with the color sensors I believe it is near impossible.

              Comment


              • #8
                Originally posted by 11343_Mentor View Post
                May I ask what you are using the color sensor for? If using it for sampling for gold mineral location, I highly suggest you abandon this idea and go with the TensorFlow approach. We wasted countless hours trying to use the color sensors to no avail. You have to be too close to the mineral, it is too slow, and it is affected too much by lighting in the room. Our Tensorflow implementation is now 100% over 50 trials. Yes, there is work involved in getting Tensorflow to 100%, but with the color sensors I believe it is near impossible.
                If they have ZTE Speed phones (I think this is the only model) they do not have the opportunity to use Tensorflow.

                Comment

                Working...
                X