Announcement

Collapse
No announcement yet.

REV Expansion Hub - Best Practices and FAQs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • REV Expansion Hub - Best Practices and FAQs

    Hey everyone, it is that time of the year where teams are getting robots up and running likely for the first time in a while or with new team members working with the REV Expansion Hub for the first time. Hoping this thread can serve as a bit of a best practices/FAQ for the REV Expansion Hub. As always if you have any questions feel free to call or email [email protected]

    Our firmware update failed and the Hub is unresponsive

    Have no fear, REV Hub Interface software is here! You can use the firmware section on the REV Hub Interface Software to recover the Hub.
    1. Install the REV Hub Interface Software (www.revrobotics.com/software)
      1. You may need FTDI Drivers depending on the version of Windows you are running: http://www.ftdichip.com/Drivers/VCP.htm
    2. Plug your Expansion Hub into your computer
    3. Boot the REV Hub Interface Software
    4. Select Firmware tab then click the Choose .bin file button
      1. Select the version of the firmware you want to install (hint it comes with the latest and greatest version)
    5. Let the firmware install
    6. After install is finished, select Connect on the REV Interface Software.
      1. Hub should read connected and have a Green Light showing connection

    Our LED is not lighting on the Expansion Hub

    Have you tried to reset the firmware? If not try the above steps for firmware reset.

    If you have tried to update the firmware:
    1. Plug your Expansion Hub into a Windows PC
    2. Open the Device Manager in Settings
    3. Click the arrow next to Universal Serial Bus Controllers
    4. Find USB Serial Converter under the menu
    5. If this is not present there maybe a larger issue with your hub. Email [email protected] with details of the steps you have taken so far, any order numbers for the Expansion Hub (if you have them), and we will work from there.
    As a note, one of the failures we have seen this year is from plugging the battery charger directly into the Expansion Hub. DO NOT DO THIS. It will damage the Hub and cause eventual failure of the device.

    Our Hub is not being recognized through the Phone or issues seeing the Second Hub

    Try running through these Hub startup procedures:
    1. Unplug the USB from your RC phone
    2. Power off the main robot switch (turn off 12V power from the Expansion Hub(s))
    3. Wait a few seconds
    4. Turn on the Main Robot Switch (supply 12V power to the Expansion Hub(s))
    5. On your RC phone, press the square button and the swipe to close the FTC RC app
    6. Plug your RC phone into the USB-- the FTC app should automatically open
      1. If the app doesn't automatically open you do not have a good connection from the Expansion Hub to the Phone. Check your cables first, followed by the micro and mini USB connections.
      2. Consider using some form of strain relief (like the REV USB Retention Mount or one of the many 3d printable options available on places like Thingiverse) to keep the USB-mini port from being damaged.
    If the issue of seeing the Second Hub continues after running through the start up procedures:
    1. See the Expansion Hub Guide (www.revrobotics.com/resources)
    2. Rerun through the configuration and addressing steps in the guide
      1. Make sure the leader hub is addressed as 2 and the follower hub is addressed as 3.
    3. Connect the two Hubs to each other has described in the Expansion Hub Guide
    4. Install the REV Hub Interface Software on a PC if not already done
    5. Plug the Leader Hub into the Computer with the REV Hub Interface Software installed.
    6. Press Connect
    7. The DC Motor page should split in two with 8 total motor controls available if both are functioning properly.
      1. Also, you can look at the LEDs on the Hubs. They should be solid Green with occasional blue blinking.

    Just as reference there are a good amount of resources on www.revrobotics.com/resources that can help get you ready to go this season.
Working...
X