Announcement

Collapse
No announcement yet.

Issues with Wifi Direct Connection and FTC Driver Station

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues with Wifi Direct Connection and FTC Driver Station

    At our last qualifier a few weeks ago, my team and I experienced multiple technology issues that greatly affected our performance. We are now hoping to resolve these to allow us to fully compete at our next qualifier. As we are a fairly inexperienced team, any help you could provide would be greatly appreciated. We are using modern robotics modules with a ZTE speed phone and Android Studio.

    Our main issue was with the wifi direct connection between the robot controller and driver station phones, almost identical to the one described here:

    https://ftcforum.usfirst.org/forum/f...ver-controlled

    This team attributed the problem to the FTCRobotControllerActivity file, but we are unsure of what that is and how to fix it. We have already updated the phones to version 3.6 and made sure instant run is disabled, but have not been able to find any other information on this file.

    We also experienced a disconnect between the gamepads and the driver station phone. During our qualifier, there were many instances where pressing start and A or B on the gamepads did not register at all on the phone, even though all of the physical connections appeared to be fine. A few times, the controllers were both registered before a match, but as soon as we pressed start they disappeared. We were thinking that this could be because we forgot to change the "Connect to PC" setting on the phones after updating them, but we would like to be sure so that this does not happen to us again. Any help on this would be much appreciated.
    Our robot has been disconnecting quite a lot recently so we decided to purchase Samsung Galaxy S5 phones. We installed the app and matching android studio

  • #2
    Regarding driver station to gamepad disconnects, see this post: https://ftcforum.usfirst.org/forum/f...external-power

    Comment


    • #3
      Team 8582,

      I'm sorry you are having issues with your control system.

      Regarding the disconnects, have you checked your USB cables and adapters? For the Driver Station and gamepad issue, in my experience, I have seen the Micro USB OTG Adapters (the cable that plugs directly into the Micro USB OTG Port on the Android phone) wear with time. The retention mechanism with these adapters get weaker over time with constant use. Similarly, with the Driver Station, I have seen the non-powered USB hubs occasionally develop problems over time with constant use.

      Particularly for your driver station issues, have you tried purchasing new OTG adapters and a new USB hub and see if it addresses the disconnect issues?

      Similarly, on the Robot Controller side have you checked to make sure the wiring is sound and that the connections are secure? Since you are using the Modern Robotics modules (I reread your post) the USB cables that were shipped by Modern Robotics seem to have connection/retention issues.

      Have you tried replacing the USB cables on your robot with better quality and newer USB cables?

      Also, have you tried replacing the Micro USB OTG adapter on the robot side (the cable that plugs directly into the Android phone on the robot)? These wear with time and can lose their ability to stay connected.

      Tom

      Comment

      Working...
      X