Announcement

Collapse
No announcement yet.

Trying to embed OpenCv into project..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to embed OpenCv into project..

    In the imports section I have this line of code:
    import com.qualcomm.robotcore.robocol.PeerAppRobotControl ler; I get this error: Cannot resolve symbol PeerAppRobotController When I browse the robocol contents I really don't see it there..
    Please advise.

  • #2
    I've been following a walk-through that is a bit old, Copied the whole FtcRobotControllerActivity.java file from tutorial which is based on an older version of FtcRobotControllerActivity.java.

    Restored the new version file from GitHub and copied code from older version selectively, worked like charm.

    Comment


    • #3
      Where is the new GitHub version?

      Comment


      • #4
        anwar, who's "been following a walk-through"... where?

        Comment


        • #5
          I'll attempt to upload a PDF with instructions that have worked for me. These are based on a tutorial from Gearbox 4h Club (team 7393). That tutorial is a couple of years old. I found that some changes were needed, perhaps because I'm using a newer version of the FtcController project, a newer version of OpenCV, and a newer version of Android studio. In addition, that tutorial includes code for controlling the camera, grabbing frames, etc. I'm doing that through VuforiaLocalizer.getFrameQueue(), and have not included all that stuff. FtcOpenCV.pdf

          Comment

          Working...
          X