Announcement

Collapse
No announcement yet.

Problems with the platform

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with the platform

    Hi everyone! We've met some problems with the platform, which are very annoying. Could someone help me? Thx. These are the problems my team is facing now.

    1. Opmode resets - While we were running the opmode, sometimes the opmode and the interface on DS app just reset. I had to choose the opmode and click on "init" and start button again.

    2. DS App's information become gray - Sometimes while we were running the opmode, two phones just disconnected and the interface on DS App turned gray. Sometimes I could solve this problem by reopening DS App. Sometimes the RC phone showed up a task to ask for the permission of Wifi direct connection with the DS phone. (By the way, we are now using Mi 4 as both RC and DS phones, because China committee suggests Chinese teams using it.)

    3. Couldn't find some modules after reconnecting to RC phone - After downloading the new program to RC phone, I connected the phone to PDM, then sometimes it couldn't find some modules. Before I downloaded the new program, everything worked correctly. And I couldn't solve this problem by reopen apps. However, restart everything especially pulling out and replugging the Micro-USB cable with the phone helps.

    Is there any cable or adapter that can protect RC phone's micro-usb port? For example, I can use this thing to connect to PDM, can download programs and I can use it for charging as well. I use an OTG adapter which has a swith for DS phone to connect two gamepads and charge the phone. But this adapter don't allow data input, so the program can't be downloaded to RC phone.

  • #2
    Issues 1 & 2 are most likely due to wifi disconnect Issues. I haven't worked with Mi 4 phones so I can't provide much help here, but some teams have fixed some wifi problems by preforming a factory reset on their phones.

    Issue 3 is the dreaded USB disconnect issue that we all are struggling with. My team had these problems go away by buying different USB cables.

    Hope that helps!
    Luke

    Comment

    Working...
    X