Announcement

Collapse
No announcement yet.

What versions of Studio and ZTE Speed can we use?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What versions of Studio and ZTE Speed can we use?

    Is there any specific version of either Studio or the ZTE Speeds that we need to use? Especially for the phones, does it matter if we get every update as it comes out? Or will everything only work with one specific version?

  • #2
    As long as ZTE Speed updates keeps the verison 4.4, you can apply any update. As of now, you can use any version of Android Studio 1.2+.

    Comment


    • #3
      The version of Android Studio itself, as a tool, isn't as important as the version of the Android SDK. Thankfully, the buildscripts specify the exact API levels and build-tools that must be used. You'll simply have to install those versions (with multiple versions easily living side-by-side) using your Android SDK Manager.
      FTC6460 mentor (software+computer vision+electronics), FPGA enthusiast. In favor of allowing custom electronics on FTC bots.
      Co-founder of ##ftc live chat for FTC programming--currently you may need to join and wait some time for help--volunteer basis only.

      Comment


      • #4
        Originally posted by dmssargent View Post
        As long as ZTE Speed updates keeps the verison 4.4, you can apply any update. As of now, you can use any version of Android Studio 1.2+.
        Is that 4.4.x, or just 4.4?

        Comment


        • #5
          Originally posted by ftcbisonb View Post
          Is that 4.4.x, or just 4.4?
          Any Android version <5.0. This is just a guess based on observing the market, but based on where the ZTE Speed is in its life cycle it is unlikely that it will get a 5.0 update.

          Android 5.0 introduced a bug in the Android USB libraries. Fixes are slowly rolling out to Android devices. See https://code.google.com/p/android/is...tail?id=159529

          Comment

          Working...
          X