Announcement

Collapse
No announcement yet.

Errors on first command on to yellow jacket matrix motors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors on first command on to yellow jacket matrix motors

    We are using yellow jacket matrix motors and get stack traces in the code the first time we make a motor command during the first opmode of a robot cycle. We initialize the motors just like we do with any others during robot init, and this only happens with the motors configured as "12V Matrix Motor". Anyone have any clues? The 1st log entry seems to indicate a n'ack received suggesting the motor was not config'd before enabling.

    The stack trace looks like:
    Code:
    11-17 09:36:48.001 10806 10969 V RobotCore: nack rec'd mod=2 msg#=121 ref#=0 reason=MOTOR_NOT_CONFIG_BEFORE_ENABLED:50
    11-17 09:36:48.001 10806 11772 E LynxMotor: exception thrown during lynx communication
    11-17 09:36:48.001 10806 11772 E LynxMotor: com.qualcomm.hardware.lynx.LynxNackException: (DQ2D2G0X #2) LynxSetMotorChannelEnableCommand: nack received: MOTOR_NOT_CONFIG_BEFORE_ENABLED:50
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.hardware.lynx.commands.LynxRespondable.throwIfNack(LynxRespondable.java:325)
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.hardware.lynx.commands.LynxRespondable.send(LynxRespondable.java:239)
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.hardware.lynx.LynxDcMotorController.internalSetMotorEnable(LynxDcMotorController.java:221)
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.hardware.lynx.LynxDcMotorController.internalSetMotorPower(LynxDcMotorController.java:543)
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.hardware.lynx.LynxDcMotorController.setMotorMode(LynxDcMotorController.java:373)
    11-17 09:36:48.001 10806 11772 E LynxMotor:     at com.qualcomm.robotcore.hardware.DcMotorImpl.internalSetMode(DcMotorImpl.java:322)
Working...
X