Announcement

Collapse
No announcement yet.

How to run Autonomous and Teleop using the FCS?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to run Autonomous and Teleop using the FCS?

    We desperately need an answer for the following question. We loaded FTCautofull.vi, FTCteleopfull.vi, and program chooser.vi on the NXT. We run the FTCautofull.vi. It will wait until "enable" from the Field Control System. After 40 seconds, the robot will stop there. However, we have no way to operate the FTCteleop.vi after the FCS moved on to the teleop period. Please guide us on how to get both autonomous and teleop programs running under the control of FCS.

    We truly appreciate your help.

    Thanks,
    Esther

  • #2
    If you are using RobotC you must "pre-select" your teleop program through the menu, Robot>NXT Brick>Joystick - Game.... there will be a dropdown box in that window that will let you select a program on the brick as your teleop program

    Comment


    • #3
      Thanks very much for the reply. But we use Labview. We did run the program chooser. However, it said "Error saving config file". I guess it did not generate a FTCconfig file properly. We could not get the teleop program running at all during the teleop mode. HELP, please!

      Comment


      • #4
        Is there sufficient storage space on the NXT for the Program Chooser to create the FTCCong.txt file?

        Comment


        • #5
          I believe we had enough space, since we tried several different programs including the teleopbasic from the template. None of them worked. It showed the same error every time. Thanks though. I will double check it tomorrow. Other thoughts?

          Comment


          • #6
            Originally posted by 2010FTC3487 View Post
            Thanks very much for the reply. But we use Labview. We did run the program chooser. However, it said "Error saving config file". I guess it did not generate a FTCconfig file properly. We could not get the teleop program running at all during the teleop mode. HELP, please!
            I was given this error only when I did not have enough space. I would recommend going into the "Settings" section of the NXT, choosing delete files, and deleting all the files that the NXT will allow you to delete from that menu (you should almost always delete all "Sound" and "Try" files off of the NXT unless you know that you will need them) - you can always get any program you accidentally delete back by just updating the firmware on the NXT. After this reload ONLY your current autonomous program, teleop program, and program chooser.
            Your idea of going into Program Chooser to create the config file is the only way to do this with LabView that I have been able to find.

            If you continue to have problems, in LabView while connect via USB to the NXT - go to Tools -> NXT Tools -> NXT Terminal
            Note: The NXT Terminal system is very buggy and laggy. It generally takes about 5 minutes for it to simply load and recognize my NXT, so be patient.
            Once your NXT has been chosen (use the "Find NXT..." drop-down box), use the 5th button in the "File Operation" section. This will defragment the NXT, and will hopefully give you some extra space. Also note: the defragmentation process is just as, if not more buggy then the Terminal window so it can take anywhere from 2 minutes to half an hour.

            On my NXT, I am currently able to have samostat, Program Choose, and three other programs (generally 1 teleop, and two autonomous) while still being able to save the config file because I have deleted all the unnecessary things from my NXT. I believe I would be able to get up to four other programs if I defragment my nxt.
            Last edited by PSH407; 12-01-2010, 11:07 PM. Reason: updating info

            Comment

            Working...
            X