Announcement

Collapse
No announcement yet.

FCS can select NXT, but cannot connect to it

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FCS can select NXT, but cannot connect to it

    We are using a LinkSys WRT110 router as the FCS. We followed all the steps in the Router Configuration for Teams guide to set up the router and to flash the Samantha. We are using WPA2 PSK authentication and AES encryption. In the FCS, we are able to select our brick, but it does not connect; the status says "Not connected to XXXX at 192.168.2.100." When we run samostat on the brick, the IP address is 192.168.2.100.

    We appreciate any suggestions for troubleshooting.

  • #2
    Originally posted by MonkeyMadness5096 View Post
    We are using a LinkSys WRT110 router as the FCS. We followed all the steps in the Router Configuration for Teams guide to set up the router and to flash the Samantha. We are using WPA2 PSK authentication and AES encryption. In the FCS, we are able to select our brick, but it does not connect; the status says "Not connected to XXXX at 192.168.2.100." When we run samostat on the brick, the IP address is 192.168.2.100.

    We appreciate any suggestions for troubleshooting.
    We suspected the authentication and encryption, so we set up the router and the FCS to be an open network. The problem remained the same. We next tried connecting to a Linksys E1000 router that had been used as an FCS and reflashed our Samantha. It worked fine.

    So the problem seems to be the WRT110 router, which is surprising since it is very similar to the Linksys E1000 that works.

    Comment


    • #3
      Google tells me that the WRT110 router (only) officially supports wifi-g networks, while the FCS requires a wireless-b network to run. That may have been the issue.
      Lead programmer for FTC team #6424, the 'Oly Cow.
      https://www.facebook.com/pages/The-O...60019847470634

      Comment


      • #4
        Originally posted by Ernest314 View Post
        Google tells me that the WRT110 router (only) officially supports wifi-g networks, while the FCS requires a wireless-b network to run. That may have been the issue.
        It definitely has a Wireless-B only setting.

        Comment


        • #5
          Was it on that setting? Wireless-B only?
          Lead programmer for FTC team #6424, the 'Oly Cow.
          https://www.facebook.com/pages/The-O...60019847470634

          Comment


          • #6
            Originally posted by Ernest314 View Post
            Was it on that setting? Wireless-B only?
            Yes. We followed all the recommended settings.

            Comment


            • #7
              Is the router fully updated? I have a BEFSR41 (old Linksys wired router that looks like a WRT54G, which is of the same era as your router) at my house, and the Samantha, for some reason, didn't work when that router was in between the FCS and the Samantha. If I took that router out of the network, the Samantha worked fine. Once I updated that router to the latest firmware offered by Linksys, everything worked fine. I recommend going to Linksys' website and seeing if there's an updated firmware for your router.
              Max Bareiss

              FTC #248 Fatal Error (2009-2013)
              FRC #3142 Aperture (2009-2012)
              FRC #1302 Team Lionheart (2012-2013)
              ZRHS #89 Team K├╝hlschrank (2011-2013)
              ZRAC #40 Catcher in the Skye (2012)
              ISR 12: Umptysquatch 6
              Rowan University Baja SAE

              And mentoring for life.
              --
              11 seasons of FIRST in 6 years, as a student. Many more as a mentor.

              Comment


              • #8
                Thanks to a hint from the chiefdelphi FTC forum, I got the router working. It was not sufficient to select wireless-B on the router. I also had to change the wireless data rate and transmission speed from auto to 2 mbps. After that, I was able to connect the FCS to the Samantha module.

                Comment


                • #9
                  Thank you!!!

                  Originally posted by MonkeyMadness5096 View Post
                  Thanks to a hint from the chiefdelphi FTC forum, I got the router working. It was not sufficient to select wireless-B on the router. I also had to change the wireless data rate and transmission speed from auto to 2 mbps. After that, I was able to connect the FCS to the Samantha module.
                  I was having that exact same problem with the same router. I tried chiefdelphi's tip from above and it immediately fixed the problem. My only difference was that one of the settings had a slightly different name, but it worked so thanks. If anyone else has a WRT110 you will need to do this.

                  Comment

                  Working...
                  X