How do I Post to the Game Q&A Forum?

Welcome to the FTC Game Q&A Forum! If this is your first time here, please refer to the Instructions for Forum Use section before posting.

Thank you!

Posts created to sell a product or service are not permitted and will be deleted!

Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Controller not connecting to the Phone

  1. #1
    Junior Member
    Join Date
    Sep 2015
    Location
    Edison New Jersey
    Posts
    17

    Controller not connecting to the Phone

    Hello everyone I am having problems connecting my Logitech Controller to the drive station on the version 1.77

    The Start A and Star B method did not work
    The controller does work I connected it to my computer and an emulator recognized it
    The cable connecting the phone to the controller works, I tested it by connecting the adapter to the Robot Controller from the Power distribution module

    It seems that the controller is not getting powered as when I press the mode button on the controller it doesn't light up, but it lights up on the computer.

  2. #2
    Junior Member
    Join Date
    Sep 2015
    Location
    Edison New Jersey
    Posts
    17
    I also tried restarting the phone as well as switching the apps on the Robot controller and the Driver Station.

  3. #3
    Senior Member
    Join Date
    Mar 2015
    Location
    Oklahoma
    Posts
    967
    It sounds like your gamepad controller is in the wrong mode.

    Is the switch of the back of the controller set on "X"? If not, can you change it to X and try it again with the gamepad.

  4. #4
    Junior Member
    Join Date
    Sep 2015
    Location
    Edison New Jersey
    Posts
    17
    Quote Originally Posted by dmssargent View Post
    It sounds like your gamepad controller is in the wrong mode.

    Is the switch of the back of the controller set on "X"? If not, can you change it to X and try it again with the gamepad.
    Thank you so much, it worked as soon as flipped the switch to X. I am guessing that x stands for x-input, anyways thank you so much for your help.

  5. #5
    Junior Member
    Join Date
    Sep 2016
    Location
    Wahroonga
    Posts
    1
    Hello,

    I am having the same problem, but my controller is set on "X". I am using a ZTE phone, Model Z812 Android 5.1. Do you know what else can I do to make work? The wifi direct works with the other phone I can connect and select the Op mode but is just missing the controller to be able to drive the robot.

    Thanks

  6. #6
    Senior Member
    Join Date
    Nov 2015
    Location
    Carol Stream, IL
    Posts
    161
    Note that the ZTE Maven (I believe that's the model Z812) is not an approved phone, and Android 5.1/Lollipop is not an approved Android version. You can find the list of approved phones and the supported operating system version for each phone in the Game Manual 1. While I have had some success in using other phones, you will not pass inspection with that phone. You should probably work on getting approved phones.

    Lollipop is known to have issues with USB, though I believe not these exact symptoms.

  7. #7
    Senior Member
    Join Date
    Jun 2015
    Location
    Rockville
    Posts
    143
    Usually whenever the Start A method isn't working for us, we unplug every USB connection to the phone and then restart the phone and that seems to work. If your driver station USB hub has a light, that usually helps out in telling whether it is a wiring problem or a software problem.

  8. #8
    Member
    Join Date
    Sep 2016
    Location
    Rosemead, CA
    Posts
    36
    Ongoing discussion of similar problem over at Thread 6387 http://ftcforum.usfirst.org/showthre...ad-Connections. I can't get the gamepad to register itself with the Driver app. Start A and Start B do nothing.

    What precisely do you do with Start A? Hold Start and tap A? Hold both Start and A? Hold Start then hold A? Hold how long? I've tried lots of button gestures. Nada.

  9. #9
    Senior Member
    Join Date
    Nov 2015
    Location
    Carol Stream, IL
    Posts
    161
    You hold <start> and tap <A>.

  10. #10
    Member
    Join Date
    Sep 2016
    Location
    Rosemead, CA
    Posts
    36
    Thanks, 5294-jjkd. That's what the docs say; that's what I did (among other gestures). No go.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •